Forums | Mahara Community

Support /
Problems installing 1.3


anonymous profile picture
Deleted user
Posts: 2

11 September 2010, 5:41 AM

Hello i tried to install mahara on my webserver. 

I first created the folders mahara and maharadata in the root directory. then i uploaded all files to mahara and chmod maharadata to 777.

now when i try to install mahara it says: 

 

Your defined data root directory, /httpdocs/maharadata/, is not writable. This means that neither session data, user files nor anything else that needs to be uploaded can be saved on your server. Please make the directory if it does not exist, or give ownership of the directory to the web server user if it does.

 

what do i have to fix ? btw i tried different paths to /maharadata  

anonymous profile picture
Deleted user
Posts: 9

14 September 2010, 8:20 AM

Hi i m also new to mahara,

but wat i suggest u is to create ur mahara directory in home folder

& give 777 permission to home folder...i think it would work out.

& don;t forget 2 assign datapath of your maharadata into config.php file.

sory..if i said wrong...as i m very new 2 mahara..jst trying 2 help u out of my knowledge.

anonymous profile picture
Deleted user
Posts: 214

14 September 2010, 11:25 AM

Hi Marc,

You need to make sure that your maharadata directory is writeable by the user that your web server runs as.

In the case of a Debian-based server for example, apache2 runs as the user www-data. You'd therefore need to change the ownership of your mahradata directory to suit - for example:

chown www-data:www-data maharadata

Hope that this helps,

Andrew

3 results