Forums | Mahara Community

Support /
Problem with .htaccess, curl or something else?


11 August 2010, 8:39 AM

Hi, I am trying to install Mahara, and first of all I saw in my browser:

500 Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin@kreativno.rs and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.
Apache Server at www.porto.kreativno.rs Port 80

I follow the instructions on http://wiki.mahara.org/System_Administrator%27s_Guide/Installing_Mahara

It's Mahara 1.2, on Linux, with mySql

After that, I receive some advices fom other Mahara users, and I delete some rows from .htaccess:

php_flag register_globals off
php_flag magic_quotes_runtime off
php_flag magic_quotes_sybase off
php_flag magic_quotes_gpc off
php_flag log_errors on
php_flag allow_call_time_pass_reference off
php_value upload_max_filesize 50M
php_value post_max_size 50M

Now in my browser appears:

Mahara: Site unavailable

Your server configuration does not include the curl extension. Mahara requires this for Moodle integration and to retrieve external feeds. Please make sure that curl is loaded in php.ini, or install it if it is not installed.
Tehnical support at hosting company said that on server is included curl extension. I am afraid that I disable that when I delete that rows in .htaccess, bat with them, Mahara don't work at all...
More details abaout my situation is on https://bugs.launchpad.net/mahara/+bug/614179 but there admin's said to me that is better to post my question here.
Can anybody help me to install Mahara and integrate it with my Moodle?
Thank you in advance...
Andrew Nicols's profile picture
Posts: 214

13 August 2010, 10:10 AM

Hi Snezana,

I think you probably need to get in contact with your hosting provider again - nothing in the .htaccess will disable the curl extension.  That said, looking again at the URL you've mentioned, you no longer receive the curl error.

The error you're now getting about your dataroot not being writable is probably because you've got it misconfigured.  The dataroot you've specified is /maharadata.  I very much doubt that you'll be able to write to this directory on your server.  You'll have to set your dataroot directory to something that your web user can write to.  You may need to contact your host for support on this one if you can't work it out.

There's also the requirement that your dataroot directory should not be within your htdocs folder. As an example, if your files are uploaded to somewhere like:
/home/snezana/public_html
Then you could set your dataroot directory to something like:
/home/snezana/maharadata

As I say, this will all depend upon how your hosting provider has things set up.

The good news though is that once you've fixed the problem you have with your dataroot, there are only two more tests before you can install mahara :)

Andrew

14 August 2010, 3:45 AM

As you see, meanwhile they really include curl extension, and I see that new error in the same time as you.

I can not even see nor maharadata neither moodledata folders in Total Commander, but I can see them these morning in SmartFTP. Now I can't see them at all. Very strange... My Moodle on kreativno.rs don't work too. All that happens yesterday afternoon...

That hosting company have not technical support till Monday...

Tahnk you for your answer, I must wait till Monday to see what's next...

Andrew Nicols's profile picture
Posts: 214

16 August 2010, 3:32 AM

Hi Snezana,

The dataroot folder you mention cannot be created.

At present, you're trying to specify a folder such as /maharadata.  This setting is specified in the same config.php you gave your database username and password.

The maharadata setting is what's known as an absolute path so using a setting of /maharadata means that the dataroot does not simply go in the same directory as your config.php, but at the root of the drive.

That is to say that if it were windows, it would be equivalent to c:\maharadata and I very much doubt that you have permission to write to this folder.  The folder you need to specify should probably be something like /home/snezana/maharadata. This would be the equivalent of c:\home\snezana\maharadata.

You may have to contact your hosting provider to find out where your files should live.

Andrew

16 August 2010, 8:02 AM

Hi, Andrew,

I am very grateful for yours effort to help me :)

In my config.php I put this path:

$cfg->dataroot = '/maharadata';

Here is how my root looks like:

From TC and from SmartFTP I can create, delete, writw in that folders.

Moodle works with that moodledata you see on the picture.

Snezana

Andrew Nicols's profile picture
Posts: 214

16 August 2010, 9:01 AM

Based upon the information you submitted in the original bug, I would guess that you want to set your dataroot to something like:

 /VDOMAINS/<username>/maharadata

So the line in your config.php would read:

$cfg->dataroot = /VDOMAINS/<username>/maharadata'

(where <username> is your username).

Andrew

16 August 2010, 11:13 AM

Dear Andrew,

Thank you very very much!

At last it works!

This is great that tihs communiti helps to new users!

Now we will try to connect it with Moodle. I hope taht we will success. If not, I know where to ask Wink

 

 

Marcio Gandra's profile picture
Posts: 4

28 March 2011, 1:24 PM

Snezana and others who can help me... I´ll post here some screen shots of all my configuration because i´ve tried everything told in this topic but the error persist.

 www.h2art.com.br/screenshotmahara.htm

Mahara Version 1.3.4 Stable

Installation folder:
"home/mineral/public_html/marn" ( marn is a abreviation of Mining Accident Report Network  , i used it instead of "mahara" name. )

Data root:
Permissions: 777
"home/mineral/data" ( 2 levels behind mahara installation folder )

Config.php:
$cfg = new StdClass;
$cfg->dbtype   = 'postgres8';
$cfg->dbhost   = 'localhost';
$cfg->dbport   = null;
$cfg->dbname   = 'portaldamineracao';
$cfg->dbuser   = 'admin';
$cfg->dbpass   = 'xxxxxxxxx';

$cfg->dbprefix = 'mineral';
$cfg->wwwroot = 'http://www.domain.com.br/marn';
$cfg->dataroot = '/home/mineral/data';
$cfg->emailcontact = 'email@email.com.br';

Htacess:
( removed all php flags )


<Files config.php>
    Order deny,allow
    deny from all
</Files>
<Files .htaccess>
    Order deny,allow
    deny from all
</Files>
<Files lib.php>
    Order deny,allow
    deny from all
</Files>

<IfModule mod_headers.c>
    Header unset ETag
</IfModule>
FileETag None

My host:
Shared hosting but with all the necessary resources to run.


8 results