Forums | Mahara Community

Support /
Mahara: Site unavailable

M G's profile picture
Posts: 3

31 January 2009, 5:29 PM


 I have uploaded the Mahara files to this site but I am still getting this error.

 "Your defined data root directory, /public_html/directory/, is not writable. This means that neither session data, user files nor anything else that needs to be uploaded can be saved on your server. Please make the directory if it does not exist, or give ownership of the directory to the web server user if it does."

The permissions are set to 777 and the directory is in the main public_html of the hosting account.

It is a shared hosting, and is an addon domain name. so, in my hosting control panel, I have : public_html, then a folder called , it did not work whether the directory was inside folder or in the main public html.

I am checking with the hosting company, but if you can help too, it will be great.

thank you.


Nigel's profile picture
Posts: 1643

31 January 2009, 6:23 PM

Hi - you have specified dataroot wrong. It is an absolute filesystem path, not a web address or a relative path. Please see the installation instructions for more information.
M G's profile picture
Posts: 3

31 January 2009, 8:30 PM

ok, thank you. I had to add /home/ to the path.

I have another problem though, I am still getting that register_globals is On, but I did turn it off in the php.ini.

and I am getting this error:" ould not execute command: CREATE TABLE config ( field VARCHAR(255) NOT NULL, value TEXT, CONSTRAINT PRIMARY KEY (field) )TYPE=innodb

Call stack (most recent first):
  • execute_sql() at /home/ghaddar/public_html/
  • execute_sql_arr() at /home/ghaddar/public_html/
  • install_from_xmldb_file() at /home/ghaddar/public_html/
  • upgrade_core("CREATE TABLE config (

  • field VARCHAR(255) NOT N...", true
    ) at /home/ghaddar/public_html/

  is that related to the register_globals? or it is another problem? and why it says type=innodb? I specified the database as mysql5.

Thank you

M G's profile picture
Posts: 3

31 January 2009, 9:29 PM

The register_globals is off, but I am still getting the database error. how I can solve it?


Nigel's profile picture
Posts: 1643

31 January 2009, 10:57 PM

Hi - the type=innodb thing is irrelevant, innodb is a type of mysql table.

The database error could be because you're on a shared host and are sharing the database with other users, one of whom has created a database table called 'config'. If you think that's the case, try using the $cfg->dbprefix setting.

Sandro Alves's profile picture
Posts: 1

06 July 2009, 7:01 AM

Hi Nigel,
i have the same problem... i don't understand what you mean with "try using the $cfg->dbprefix setting"?!
i put in the config.php: "$cfg->dbprefix = 'sandroalves';
but it doesn't works too...

sorry for my bad english, i'm from switzerland :)

Penny Leach's profile picture
Posts: 228

06 July 2009, 8:53 AM

Grüezi from Zürich!

Which problem exactly were you having? There were two problems described in this thread ;-)

If you can paste the exact error message you're getting that would help a lot :)


7 results