Forums | Mahara Community

Support /
Slow response with external database


Mark Olson's profile picture
Posts: 2

21 June 2010, 4:50 PM

I have noticed a very slow response time when I have the database on a dedicated server vs running it from the webserver.  I have an older install (v1.1.6) that has the DB on the dedicated database server and it does not reflect this problem. 

Any thoughts?

François Marier's profile picture
Posts: 411

21 June 2010, 5:37 PM

Hi Mark,

Can you tell us what type of database you are running (and what version) as well as what operating system this is running on?

A dedicated database server can be slower than a local one because it introduces extra network latency, but it certainly works fine for many of the Mahara sites we host.

What is the network connection between the web server and the db server? A private gigabit network? A shared 100 Mbit network? A direct NIC-to-NIC connection?

Cheers,

Francois

Mark Olson's profile picture
Posts: 2

21 June 2010, 7:32 PM

Database Server:
-MySQL 5.1.46
-Windows 2003 Server

Mahara Server:
-Ubuntu 10.04 LTS
-(Also mirrored this on Ubuntu 8.04 LTS with the same results)

Database Network Connection:
-Gigabit dedicated VLAN

This is running in a VMware cluster with dedicated network links and VLANs for database server connections.

The strange thing is that I have a Mahoodle install on a Ubuntu 8.04 LTS server with the external database that works perfectly.  I have replicated the setup of this server just to make sure that I did not introduce any complications to the equation and it still is slow on that server. 

3 results