Forums | Mahara Community

Support /
Fresh local install


anonymous profile picture
Deleted user
Posts: 9

09 June 2010, 7:59 AM

I am trying to set up a local install of mahara 1.2.4.

I'm using mysql as I don't intend to upgrade and it will only be used for dev testing.

Mahara fails to connect to mysql but shows no errors. There is no apache error, no maharadata log or mysql error. I get a server time out after30 seconds and a blank screen.

Tracing through the code it appears to fail on adodb.inc.php Connect function and as $forseNew is default false the _connect is failing. 

it appears to fail on checking the adodb_phpver so never creates a connection_id, is there a method of getting any error out. If I print the adodb_phpver it outputs 20480

I'm running on wamp; apache 2.2.11, mysql 5.1.33 php 5.2.9

any advice would be appreciated,

cheers.

anonymous profile picture
Deleted user
Posts: 9

09 June 2010, 9:16 AM

Okay I'm even more confused now as I've tried to get it to return an error of some sort but nothing is being returned, it's as if it's just not executing the call at all.

 

I wrote a simple test to check the database as below:

[code]

$argHostname = 'localhost';
$argUsername = 'root';
$argPassword = '';
$dbName = 'mahara124';

$link = mysql_connect($argHostname,$argUsername,$argPassword);
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
mysql_select_db($dbName,$link);

$sql = "Create table demo(`id` int(10) not null, `name` varchar(20) not null) ENGINE InnoDB";

if (mysql_query($sql)){
    echo "added table";
}else{
   echo "error ".mysql_error();
}

mysql_close($link);

[/code]

This works fine and creates the table without any issues.

I've double checked the UTF8 character set and InnoDB type so I'm at a loss as to why the install connection fails. I'll try an older version and see what happens.

anonymous profile picture
Deleted user
Posts: 9

09 June 2010, 10:59 AM

I have tried 1.2.3 now and I get the same timeout as the error is being built in lib/errors.php

I guess it must be a db issue but I have no idea what error is being generated.

Errors are set to output in php.

anonymous profile picture
Deleted user
Posts: 9

11 June 2010, 3:23 AM

I have succumb to installing postgresql, It's early days yet but connecting for the first time was not fun. The documentation covers the admin log in details but not the details for accessing the initial postgres database so this lost me alot of time as I was not able to create the initial database. I tried the usual admin and my password but it would not accept it, No where in the docs does it say that the default database/server username is postgres..... frustrating.

However, all problems have been overcome and finally 3 days later I have my first local install of mahara to play with, and next to me is teh Mahara 1.2 ePortfolio Beginners Guide.

4 results