Forums | Mahara Community

Support /
leap2a import

David King's profile picture
Posts: 7

11 May 2010, 4:50 PM

I'm trying to import some leap2a files into my Mahara server but every time I do it gives me the error:

Mahara: Site unavailable

A nonrecoverable error occured. This probably means you have encountered a bug in the system


The files were exported from another Mahara server (running the same version of Mahara) and I've even tried exporting a profile and re-importing it back into the same server and it gives the same error.

Has anyone encountered this error or has anyone been successful in importing leap2a files?  I've filed a bug on this but I'm hoping the community has found a work-around that might be faster than getting the bug fixed.

Craig Eves's profile picture
Posts: 104

11 May 2010, 6:17 PM

Hi David

It looks like this has been resolved in the bug report -

The import does work but the username and email need to be one that isn't existing the mahara that it is being imported to.

There is also a bulk import script that has been developed - I think this is available in the mahara code repository - Richard M will be able give more details if required.





François Marier's profile picture
Posts: 411

11 May 2010, 7:50 PM

The bulk import script will be available in 1.3.

Please note however that it is not officially supported. It's there for your convenience, but if it breaks: "patches welcome" :)

David King's profile picture
Posts: 7

12 May 2010, 2:11 PM

It's not resolved in the bug report, sorry.  Even if the username and email address of the leap archive I'm trying to import aren't in use in the existing Mahara server the import still fails.  The bulk import script would be nice but right now I can't even import a single user.  I'm assuming this has worked for someone or else it never would have made it into a release.  Has anyone has success with this?

Scot Aldred's profile picture
Posts: 18

12 May 2010, 11:27 PM

Hi David,

I'm having exactly the same issue, but I'm trying to import a LEAP 2.0 file generated in version 1.2.4 into another instance of Mahara that is version 1.2.3.

The error message says it does not recognise the file as a LEAP 2.0 file.

I tried importing on the same instance that I exported from and it all worked fine.

Do I need to upgrade to 1.2.4 or is there a simple fix?



Richard Mansfield's profile picture
Posts: 808

13 May 2010, 1:20 AM


There's a bug in 1.2.3 that means .zip files don't get recognised during the leap2a file upload (some browsers or OSs only I believe).

If you can, upgrade the site to 1.2.4.


David King's profile picture
Posts: 7

17 May 2010, 3:47 PM

I upgraded to 1.3.0-dev (this isn't a production server...yet) and the imports work great.  Does anyone know the projected release date for 1.3.0?

François Marier's profile picture
Posts: 411

17 May 2010, 6:05 PM

We don't have a firm date yet, but we're aiming for late July / early August at this stage.

David King's profile picture
Posts: 7

20 May 2010, 10:34 AM

I've looked for the bulk import script but I can't find it anywhere.  Does someone know if/where it exists and how well it works?  I can get by without it but it would save me the hours of importing 80 profiles individually.  Thanks!

François Marier's profile picture
Posts: 411

20 May 2010, 5:50 PM

It's only on the master branch, which might be why you haven't been able to find it:


Make sure you make a backup of your database before you run it and good luck :)



11 results