Forums | Mahara Community

Support /
Accessing files


anonymous profile picture
Deleted user
Posts: 1

05 May 2010, 9:46 AM

Hi,

We have encountered scince upgrading to 1.2 that we are unable to access files previously added to my files by the artifact owner. You get the access denied message.

You can create new files and gain access to them, so working as expected.

I would like to know, how to get the old files out of the mahara system, so I can upload them again to resolve the issue without to much pain. There are not a large number of files so dont mind doing so in this fashion. I just cant find the actual files in the data directory.

Tried searching around, but never really came up with a clear answer to how the files are stored after upload.

Tried searching the FS for *.docx and no results.

Any advice will be appreciated.

anonymous profile picture
Deleted user
Posts: 808

05 May 2010, 4:35 PM

Hi Robert, it would be good to know how this happened.  Are there any messages in the apache error log when you get the access denied?

The way it currently works is that the files themselves are all in your dataroot directory under artefact/file/originals.  There will be a bunch of files inside numbered directories -- the filenames are the same as the 'fileid' column of the artefact_file_files table in the database; the numbered directories just spread the files out a bit rather than keeping them all in the same directory.

The 'artefact' column of that artefact_file_files table references a row of the artefact table, and that row contains most of the useful data about the file, including its owner and parent folder in the my files area.

R.

2 results