Forums | Mahara Community

Support /
Problems with Mahara image blocks/profile icons and OS 10.5 server

anonymous profile picture
Account deleted
Posts: 2

12 January 2009, 19:38

I'm able to upload images via My Portfolio > My Files and they are listed there after upload, but in the My Portfolio > My Views > Edit this View, when I add An Image block, I'm unable to browse or search for the available images in the My Files area (beneath the Browse and Search tabs I have "Sorry, no artefacts to choose from"). Adding an Embedded Media block does allow us to browse/search for available movies in the My Files area. 

tail on the access and error logs is inconclusive (no errors) - I see it call it view/blocks.json.php on the first load of the An Image block when I click the gear icon, then view/artefactchooser.json.php with a query string if I click the search tab in the An Image block. 

In addition, attempting to add a profile icon (a jpg that fits the memory restrictions and size requirements) will not work (upper left corner shows Loading..., and  the Submit button constantly says Processing... with the connection to the web server still going - page never refreshes to say the profile icon was uploaded) - on subseqent trys to upload a profile icon to this page provides the following error:

There was an error with submitting this form. Please check the marked fields and try again.

followed by 

[Choose File buttton] no file selected
The file you uploaded is not valid image. It must be a PNG, JPEG or GIF file.

Again, nothing "bad" appears in the access or error logs (POST /mahara/artefact/internal/profileicons.json.php), and despite the error messages the image was selected and was a jpg. 

The best I can figure out is a) the json calls are not working as expected on OS X 10.5.6, b) the database (MySQL) isn't getting updated appropriately (is there a table I should check? or mysql logs to view), c) a change to OS 10.5 (a recent update/patch) broke some functionality, or some combination of these three. 

We are fairly certain the image block worked on an earlier version of 10.5 (probably 10.5.3 or 10.5.4) and Mahara (1.0.4), but have upgraded the OS since that time (last working for sure in June/July 08) and updated mahara to 1.0.8 (recently) in preparation for the semester. I would also mention, we're using this in conjunction with Moodle (ye olde mahoodle implmentation). 

For fun, I went back to an older verion of Mahara (as far back as 1.0.4), and the file browse problem still exists on the current version of our OS. For extra fun, I tried the 1.1 b3 release and am able to upload image to the My Files area, and then add An Image block, and select from the available images I've uploaded to My Files. But, in the beta version, I still cannot upload a profile icon (forever Loading.../Processing...)

Our specs: 

OS X 10.5.6 Server (aka Darwin 9.6.0)
php 5.2.6
added GD 2.0.34 (OS X Server doesn't ship with GD)
MySQL 5.0.45
Apache 2

Already fixed the file -Ib issue for Darwin in lib/file.php

php ini:
no disabled functions (ie exec)
upload limit: 50 MB
magic quotes gpc: off
all other php requirements should be met
Thanks for any thoughts and suggestions.  
anonymous profile picture
Account deleted
Posts: 1643

12 January 2009, 20:52

With My Files, it sounds like the call to the 'file' command isn't giving back mime types for uploaded files. I'm not surprised, because on some versions of OSX we have discovered the 'file' command behaves differently. See this bug report for more information.

The effect of this is that images aren't being detected as images, and thus you can't put them into views.

I'm not sure what the issue is with the profile icons, though it might be the same thing. You should investigate the My Files problem first, and see if the fix for that fixes the profile icon issue.

anonymous profile picture
Account deleted
Posts: 2

12 January 2009, 21:51

That did it - I had been using an earlier fix for OS X that I found here earlier last year. This also fixed the upload of profile icons. I apologize for not checking my patch. Thanks so much! 

3 results