Forums | Mahara Community

Support /
Unable to generate export

steve P's profile picture
Posts: 122

12 January 2010, 21:22

Hi, currently running version 1.2 on MySQL. Install was OK, and everything seems to be working fine except for the export portfolio feature. When I click to export either HTML or LEAP2A, I get a screen saying:

"Please wait while your export is being generated...

Unable to generate export "


How do I find out why Mahara is unable to generate the export?


anonymous profile picture
Account deleted
Posts: 808

17 January 2010, 19:28

Good question, and I'm not sure, it's not a very helpful message. The code tells me that it occurs when the data needed to perform the export was not successfully saved in the user session, so it's possible that it's cookie related, but I really don't know -- I can't reproduce this myself using mahara 1.2 and MySQL.  What browser version are you using?  Is there anything in the webserver's error log?

steve P's profile picture
Posts: 122

17 January 2010, 21:11

Richard, thanks for your reply. I've tried this in FF3 and IE7 with the same result. Errors are going to error_log in the Mahara root directory, which don't reveal anything, except that register_globals is on. Could there be a variable conflict?
steve P's profile picture
Posts: 122

18 January 2010, 2:26

Hi, I found that when I was able to turn register_globals off it fixed the problem.

 .htaccess directives were disabled on my server.

4 results