Forums | Mahara Community

Open Discussion /
Uploading images to the forum postings


Hasmeeta Shukla's profile picture
Posts: 25

06 January 2009, 4:28 PM

Hello there,

My students consistently report that they find it difficult to upload images to the forum area.  I have tried to explain the process to them several times but it is a common complaint.  Is there anyway this process could be simplified to be similar to that in the 'files' or 'profile' area for instance.  For best effect and to maintian continuity of discussion, it is best if the image is displayed in the post and not just llinked to.

Many thanks

Hasmeeta

Nigel's profile picture
Posts: 1643

06 January 2009, 8:45 PM

Currently there isn't an 'easy' way to do this in the forums, unlike blogs which make it a bit easier. The only thing I can suggest now is that your users upload the files to their files area (perhaps they open that in a new tab), then link it into the post using the image button.

I don't think there is a simple solution to this from the coding side. We'd probably want to refactor the code that allows files to be attached to blogs, which isn't a small job Frown

Edit: I found this feature request which asks for the same thing.

Hasmeeta Shukla's profile picture
Posts: 25

07 January 2009, 4:28 PM

Thanks Nigel, I will persevere, but i have only had one student so far who has been successful in thisSurprised!
Nigel's profile picture
Posts: 1643

07 January 2009, 5:38 PM

That's no good - usability is obviously a problem in this area. Hopefully we can get to fix this soon...
4 results