Forums | Mahara Community

Support /
mahara screen errors


anonymous profile picture
Deleted user
Posts: 13

20 November 2009, 11:53 AM

I am using Westhost.com to host my moodle and mahara sites.  Moodle is working just fine.

 I finshed the mahara install and it appears to work.  However, I do get screen errors.  I attached an image.

 Does this have anything to do with the  .htaccess files? 

http://dawnquinn.com/images/mahara_home_screen.png

 

dawnquinn.com/mahara

Dawn

anonymous profile picture
Deleted user
Posts: 1643

22 November 2009, 4:31 PM

It seems you've either failed to upload one or more of the language files, or they're not readable by the web server user. That's why you can see all those [[stringname/mahara]] strings all over the place. Have a look and see if you uploaded lang/en.utf8/mahara.php properly.

Once you've done that, the error message will change to a warning about "magic_quotes_gpc" being on, which you can fix by following the instructions hereCool 

anonymous profile picture
Deleted user
Posts: 13

23 November 2009, 12:20 PM

Thanks.  You are right.  I fix the problem with the strings.  I also edited the .htaccess file but without any luck.

The .htaccess file crashes the site.  I get the following error in the apache log:

[Mon Nov 23 08:16:00 2009] [error] [client 206.51.56.73] File does not exist: /home1/dawnquin/public_html/500.shtml
[Mon Nov 23 08:16:00 2009] [alert] [client 206.51.56.73] /home1/dawnquin/public_html/mahara/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
[Mon Nov 23 08:16:00 2009] [error] [client 206.51.56.73] File does not exist: /home1/dawnquin/public_html/500.shtml
[Mon Nov 23 08:16:00 2009] [alert] [client 206.51.56.73] /home1/dawnquin/public_html/mahara/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
[Mon Nov 23 08:15:47 2009] [error] [client 206.51.56.73] File does not exist: /home1/dawnquin/public_html/500.shtml

Screen error:

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Please help if you can.

Dawn


anonymous profile picture
Deleted user
Posts: 13

23 November 2009, 12:57 PM

Just so you know . . .

 This is Westhost response:

 

Hello,

On these servers, you'll need to disable magic_quotes_gpc through a php.ini file, rather than the .htaccess file. You'll want to remove the magic_quotes_gpc line from your .htaccess file, and create a text file named php.ini file with this line:

magic_quotes_gpc = Off

You will want to place a copy of your php.ini file in each folder you want to affect with this setting, as php.ini files are not recursive.

 

I will try it now to see if it works.

Dawn

anonymous profile picture
Deleted user
Posts: 1643

23 November 2009, 6:26 PM

There are instructions here about how to edit the .htaccess file if you're having problems with it.
5 results