Forums | Mahara Community

Support /
Cloud plugin


anonymous profile picture
Deleted user
Posts: 5

18 June 2015, 1:38 AM

Hello

I am running a test installation of Mahara 15.04.1 using Mamp on a Macbook.  I wanted to try the cloud file integration because we are using sharepoint at my institution.  However this is throwing an error

[17-Jun-2015 12:51:46 Europe/Berlin] PHP Fatal error:  Class PluginArtefactCloud contains 1 abstract method and must therefore be declared abstract or implement the remaining methods (IPlugin::get_plugintype_name) in /Applications/MAMP/htdocs/mahara/module/cloud/lib.php on line 0

 

What I don't know about php would drown a whale, but I am guessing that there is an issue with this plugin, however, it is difficult to tell as the wiki documentation stopped updating in 2013 and the developer site isn't very helpful.  So is anybody using this plugin? if not, is there any way of using another kind of file store.

Thanks

 

 

Patric Lougheed's profile picture
Posts: 64

18 June 2015, 2:54 AM

Hello Tina,

 

I have this installed on my development instance of 15.04.1 and although I do not get the same error I receive other errors when trying to save settings. What I don't know about PHP would not be enough to drown a whale but maybe a dolphin or some small porpoise. I can tell you that it needs a bit of updating and I have not been able to find another plugin that would give similar functionality. I am hopeful that the new web services introduced will give added functionality and ability to integrate with third party file API. I have an OwnCloud server that I would love to be able to plug into my Mahara but even webdav access is not possible.

 

Sigh!

anonymous profile picture
Deleted user
Posts: 5

18 June 2015, 3:06 AM

Thanks Patric

I had a suspicion this would be the case.  I'm beginning to think that Mahara has fallen off the edge of things and it may be time to consider a different portfolio tool.

Which would be a real shame.

T

 

Patric Lougheed's profile picture
Posts: 64

18 June 2015, 4:38 AM

Hi Tina,

I actually think things are getting better for Mahara. I have been running it for more than three years now with over 800 members and every version released it just gets better. I guess it all comes down to expectations and I use and support over 20 open source teaching tools and Mahara (with the exception of Moodle) is one of the most supported and developed platforms.

Supporting "cloud" service providers is difficult as they continually change their API which can quickly break your integration. The issue lies in third party developers who walk away from their plugin projects. Most of those can be forked and improved anyway. 

I have been able to integrate Twitter feeds, Open Badges (both Mozilla and my own), CPD (which I call learning logs), and soon the incredible SmartEvidence reporting system. Once xAPI is added and the web services are more widely adopted I believe Mahara can become the leading learning assessment platform.

I am hopeful the development community will continue to grow.

Gregor Anželj's profile picture
Posts: 348

18 June 2015, 6:08 AM

Hi.

I'm developer and maintainer of cloud plugin. I haven't thought that many people are using it since there were no comments, requests, wishes etc.

So I've maintined that plugin mostly locally for our own Mahara installation.

I am also aware that shoe methods were added to Mahara core and that is one of things that causes problems...

Please contact me through my email address (you should find it in cloud plugin source php files) if you are interested to test this plugin on development installation and help me improve it.

HTH, Gregor

Aaron Wells's profile picture
Posts: 896

24 June 2015, 11:37 AM

Hi Gregor,

I took a quick look at the cloud plugin just now (the version linked from here: https://wiki.mahara.org/wiki/Plugins/Artefact/Cloud ), and I can see what's causing this error message. Your class PluginArtefactCloud is directly extending Plugin, when it should be extending PluginArtefact.

So just change the first line of the class so it reads:

class PluginArtefactCloud extends PluginArtefact {

... and that should fix this issue. There are probably a couple of other things that need to be updated as well, in order for it to work perfectly with Mahara 15.04, though.

Cheers,

Aaron

Gregor Anželj's profile picture
Posts: 348

24 June 2015, 4:22 PM

Hi Aaron.

I've already spotted that one... ;-)

I'm working on some other minor details to make the plugin work well under 15.04.

Gregor
7 results