Forums | Mahara Community

Developers /
Calendar Artefact-v0.5.0

anonymous profile picture
Account deleted
Posts: 4

15 November 2014, 6:35

Installing above version of Calendar artefact  in Mahara v1.10.0

I downloaded the 'Calendar view of plans' artefact from plugins page.


I didn't have any issues while installing. However, clocking on 'Calendar' tab comes with the error as below-


A nonrecoverable error occurred. This probably means you have encountered a bug in the system




I have not made any hacks into core code. Upon investigating I couldn't see  any 'blocktype' associated with /calendar/  artefact. I was expecting to see a folder '/blocktype/' as per Mahara artefact development instruction.


Has anyone ran into same issues while installing 'calendar' artefact

Kristina Hoeppner's profile picture
Posts: 4049

17 November 2014, 8:18

Hello Nivedita,

Can you please check your error log to get some more information on the actual error?

Thank you



Robert Lyon's profile picture
Posts: 609

17 November 2014, 10:45

Hello Nivedita,

I've taken a quick look at this plugin and I can see that it fails to work under postgres - there are multiple errors due to database tables having reserved words for columns but there are no provisions taken for that in the php code to call info from those tables.

There are also errors for where to find the templates due to mahara 1.10 placing all templates under the /theme/raw/ directory.

This plugin looks like it will need some tidying up before it can even load correctly for mahara 1.10




anonymous profile picture
Account deleted
Posts: 4

18 November 2014, 0:30

Thanks Robert for looking into this. I have decided to not include this plugin for mahara upgrade v1.10.0 

anonymous profile picture
Account deleted
Posts: 4

18 November 2014, 0:29

Hi Kristina,

As Robert mentioned in his reply. There are number of errors within error log. However, to elaborate the issue further few more details-

Calendar plugin version-

$config->version = 2013070200;

$config->release = '0.5.0';

Mahara version

 $config->version = 2014092306; 
$config->release = '1.10.0';

Error_log as below


[WAR] 78 (lib/errors.php:457) An exception was thrown of class Dwoo_Exception. , 
[ [WAR] 78 (lib/errors.php:457) THIS IS BAD and should be changed to something extending MaharaException,, 
[WAR] 78 (lib/errors.php:457) unless the exception is from a third party library., referer: 
78 (lib/errors.php:457) Original trace follows, 
[WAR] 78 (lib/dwoo/dwoo/Dwoo/Template/File.php:153) Template "new_plan.tpl" could not be found in any of your include path(s)

[WAR] 78 (artefact/calendar/lib.php:450) Indirect modification of overloaded property LiveUser::$id has no effect

[WAR] 78 (artefact/calendar/lib.php:1087) Undefined variable: tasks_per_plan_per_day

[WAR] 78 (artefact/calendar/lib.php:354) Undefined variable: missing_field_description

[WAR] 78 (artefact/calendar/lib.php:345) Undefined index: missing_date

[WAR] 78 (artefact/calendar/lib.php:345) Undefined index: missing_title

[WAR] 78 (artefact/calendar/lib.php:499) Undefined variable: new_event



anonymous profile picture
Account deleted
Posts: 19

20 November 2014, 8:33

Hello Nivedita,

the plugin was developed in a project of TU Darmstadt that was ended in 2013.

Mahara version 1.10 ist not supported yet. I would love to bring it up to date, but right now I don't have the time. (Since the project ended, it's a hobby for me and so it doesn't have the highest priority.)

I hope to have time again soon, but I can't promise anything.



anonymous profile picture
Account deleted
Posts: 4

22 November 2014, 4:32

Hi Angela,

Thanks for getting back to me on this. Yes, that makes sense. We are not in a hurry to install the plugin- but, it was requested by some of our users. It would be nice to install during our next upgrade though. Smile

Tobias Zeuch's profile picture
Posts: 101

04 March 2015, 10:28

Hi Nivedita,

I fixed some problems the plugin had with the 1.10 version of mahara. The changes are on their own branch on gitorious at the moment, you find them here:

I did some minor changes to the appearance, e.g. you'll get to the calendar in the top right navigation bar now, next to the notifications symbol. It's not in the main menu any more.

There is one problem I haven't been able to solve so far: The event artefacts are connected with a plan. If you try to delete a plan that has events attached to it, mahara will fail (because it tries to delete all sub-artefacts first, even before triggering the delete-event)

But besides that, it seemed to work as far as I tested. If you encounter any other problems, let me know and i see if I can fix them.

I'll also stay in contact with Angela to see if we can backmerge the changes or maybe even get the calendar into the core in the future.


Klaus Steitz's profile picture
Posts: 13

07 August 2015, 1:13

Hi Angela and Tobias,

due to the shutdown of all the repositories aren´t available anymore.

Did you move the project? I was not able to find it anywhere.

I would  appreciate if it could be uploaded and made available again.

@Tobias: Did you fix all issues? Have you tested with 15.04?

We planned our update to 15.04 for next week and i have just realized that the original calendar-plugin version (developed for 1.7) does not work anymore.

You're welcome to send me your branch!


Thanks and kind regards

Tobias Zeuch's profile picture
Posts: 101

07 August 2015, 9:31

Hi Klaus,

I had solved most of the issues for the 1.10 release. I think there was a broken form if you didn't first create a plan, but besides that, adding/editing/displaying events and tasks worked. I haven't tried the plugin on a recent 15.04 yet, but I will give it a try this weekend. 

I still have my local repository and I can share it with you. I didn't migrate the project because I wasn't sure about where to. Also no one seemed interested in the calendar so far, and I didn't feel like keeping it alive only for myself. But if you suggest something, I/we can set it up again and see to the migration into 15.04


11 results