Forums | Mahara Community

Support /
html Anchor tags


anonymous profile picture
Deleted user
Posts: 35

07 July 2014, 4:08 AM

I have looked through the posts already about anchor tags and couldn't find an answer on how to fix my issue...

I have used this code <a name="user_A1”></a> as an anchor in my e-portfolio for almost a year and it still works on those pages (altering the "A1" for different anchors). Now when I try to use it in a new page it gets striped to <p>&nbsp;</p>

Any help?

Aaron Wells's profile picture
Posts: 896

07 July 2014, 12:22 PM

Hi Simha,

I can still create HTML anchors using that code. Here's an example: https://mahara.org/user/aaronw/untitled-1#user_A1

Cheers,

Aaron

anonymous profile picture
Deleted user
Posts: 35

18 April 2015, 9:35 PM

I am having this issue again of my anchor tags getting erased? 

anonymous profile picture
Deleted user
Posts: 35

18 April 2015, 9:43 PM

I have tried in both internet explorer and Firefox. I make my anchor tag in the HTML editor and save - the anchor appears. I save the text block and when I open it up again the html has been erased. This is such an essential thing to make navigation through large collections easy.

I think a simple anchor button in the text editor would be a nice addition (like they have in wikispaces). 

So I was using the anchor tag <a name="user_OVM1"></a> and after playing around a little, copying code from another anchor tag that was working and changing the ID

</p>
<p><a name="user_OVM1"></a></p>
<p>&nbsp;</p>

it stayed.... I am unsure why.

 

Robert Lyon's profile picture
Posts: 444

21 April 2015, 10:22 AM

Hi Simha,

Adding the 'Anchor' button to the text editor should be simple enough

I'll add a bug report for that: https://bugs.launchpad.net/mahara/+bug/1446400

Cheers

Robert

anonymous profile picture
Deleted user
Posts: 35

24 April 2015, 8:32 PM

Thanks Robert!

anonymous profile picture
Deleted user
Posts: 35

24 April 2015, 8:40 PM

Wow I am having a new issue with this anchor tag... before it was stripping just the anchor tag now it is now stripping the html link to the anchor, example.

I enter in - 

<a href="http://portfolios.gaiauniversity.org/view/view.php?id=8230#user_OVM3”><strong>Supporting Evidence</strong></a>

and it strips it to -

<a href="http://portfolios.gaiauniversity.org/view/"><strong>Supporting evidence page</strong></a>

 

 

7 results