Forums | Mahara Community

Developers /
link proplem on page


anonymous profile picture
Deleted user
Posts: 14

02 January 2013, 2:14 AM

Dear people,

I found a link problem on /mahara/artefact/file/sitefiles.php:

<p class="intro">

Hier kun je bestanden uploaden die in het
<a href="http://xxxxxxx/mahara/admin/site/menu.php"> links en bronnenmenu gezet kunnen worden. Bestanden in de startmap kunnne toegevoegd worden aan het loginmenu, terwijl bestanden in de publieke map aan het publieke menu kunnne toegevoegd worden.</a>
</p>
<div>
The text is in Dutch, should be the same in English. The first href is too long and the second misses </a> all together resulting in the problem that I can not upload files because the page jumps to /admin/site/menu.php.
The following would be beter, I just can not find the right file where I can make this change.

<p class="intro">

Hier kun je bestanden uploaden die in het
<a href="http://xxxxxxxx/mahara/admin/site/menu.php"> links en bronnenmenu </a> gezet kunnen worden. Bestanden in de startmap kunnne toegevoegd worden aan het loginmenu, terwijl bestanden in de publieke map aan het publieke menu kunnne toegevoegd worden. 
</p>
<div>
Greetings,
Volker Schmidt
Kristina Hoeppner's profile picture
Posts: 3864

02 January 2013, 5:19 PM

Hello Volker,

Which version of Mahara are you using? I can't see a problem in the English text on sitefiles.php. I assume that the translator forgot to put the </a> in the correct place. Unfortunately, I can't search the translation file because Launchpad always gives me a timeout when I search for a term in the sentence at https://translations.launchpad.net/mahara-lang/1.6/+pots/mahara/nl/+translate (assuming you are using 1.6).

You'll have to look in the lang folder for the string but only search for a few words and not the entire sentence as the link might be represented differently.

Cheers

Kristina

anonymous profile picture
Deleted user
Posts: 14

03 January 2013, 2:42 AM

Thanks for pointing me into the right direction...fixed it on Launchpad. The translator forgot a %s, that's why the link strechted over the rest of the text. Fixed 4 typos as well. Laughing

Greetings,

Volker

Kristina Hoeppner's profile picture
Posts: 3864

03 January 2013, 8:29 AM

Hi Volker,

Great that you had better luck than me finding it and for fixing a few other mistakes. Having the translations on Launchpad makes it easy to  work on them collaboratively. :-)

Cheers

Kristina

4 results