Forums | Mahara Community

Support /
Users cannot register themselves?


Miriam Laidlaw's profile picture
Posts: 15

02 April 2011, 2:13 AM

Hello there, we are running Mahara 1.3.2 and the site works perfectly - except that for some reason new users cannot register themselves.

There is no error message - in fact, if you click the register link on the front page, you get the registration form.

Fill it out, and you get the message:

"You have successfully registered. Please check your e-mail account for instructions on how to activate your account"

However, no email ever appears. I have had everyone who has tried to register an account tell me this same thing, and I have had to create their accounts manually on my admin login.

Oh, I should also mention that when users have done this, and received the message saying that they have successfully registered, there doesn't seem to be any sign of this successful registration anywhere when I log in as admin. There is no sign of a user awaiting confirmation or anything.

I have looked through these forums and have checked that registration is enabled in the "No institution" group. Is there a specific authentication plugin that needs to be added? Currently it has "Internal".

Your help is much appreciated.

Kristina Hoeppner's profile picture
Posts: 3422

03 April 2011, 3:16 PM

Hello Miriam,

Did you check that you can send emails from your Mahara server? Do you get any email notifications from forums etc.? Maybe smtp is not configured correctly.

You don't see any accounts in the admin area as the users will first have to confirm their email address within 24 hours. Until then nothing can be seen on the Mahara frontend for the admin.

Cheers

Kristina

Miriam Laidlaw's profile picture
Posts: 15

03 April 2011, 4:35 PM

Hello Kristina, thank you for your prompt response.

As I was not the one to install Mahara on the server, I am not sure how the SMTP was set up. Is it something that I, as a site administrator, can check, or does the person who has FTP access to the site need to check this?

Do you have a link to instructions on how to set up the SMTP?

Thanks,

Miriam

Kristina Hoeppner's profile picture
Posts: 3422

03 April 2011, 10:25 PM

Hello Miriam,

The SMTP cannot be set up from within Mahara as it is a server configuration and not a Mahara configuration.

You can check http://wiki.mahara.org/index.php?title=System_Administrator%27s_Guide/Installing_Mahara (search for SMTP) and ask your tech guys to check that mails can be sent from the server.

Cheers

Kristina

4 results