Forums | Mahara Community

Support /
NFS and Session Performance Issues


anonymous profile picture
Deleted user
Posts: 2

19 February 2010, 8:13 AM

On a recent Mahara installation we have discovered some performance issues when we decided to move the data directory to a NFS filer. We have made this decision for backup and disaster recovery purposes as our filer gives us snapshot capabilities that make disaster recovery a breeze.

We have unfortunately stumbled upon some performance issues which we have narrowed down to where we place the session directory. The symptoms were (tracked down with xdebug) php:session_start taking up to 30 secs(!) to complete when the sessions directory was placed on the filer.

If we make a symbolic link from the filer to a copy of the session directory held on the local server there are no performance issues, this maintains the directory structure and Mahara flies along and there are no other issues as far as we can see.

What I'm hoping you can tell me is are we making trouble for ourselves now, or in the future, by moving the sessions directory on to the local system.

PS Thanks for Mahara, its an impressive product and it is recognized as so by staff and students who are now fairly clamouring for it.

François Marier's profile picture
Posts: 411

21 February 2010, 9:15 PM

Hi Dean,

If you are only running Mahara on a single web server, then your scheme should be fine.

I'm very surprised that it takes that long to create a file on the NFS server though, 30 seconds is a long time!

 Cheers,

Francois

anonymous profile picture
Deleted user
Posts: 2

22 February 2010, 6:38 AM

Hi Francois,

I suspect it is some sort of file locking paranoia on the server which (after Googling) seems to occur occasionally with php and NFS. No problems now, its all running smooothly and FAST.

Thanks,

Dean

Nathan Friend's profile picture
Posts: 12

13 April 2011, 10:38 AM

Hello Dean,

I'm so glad you posted this.  We were experening the same 30 sec locking over NFS.  I've used the local folder symlink fix as sugested and it works like a charm.

 

Cheers,

 

Nathan.

4 results