Web Pages-2009
	Date
	Task/Action
	Resources
	Homework Further Action

	Lesson One
	File Formats 
JPEG Photo Format 
GIF Flattened drawings animations 

PSD (native Photoshop file)
TIFF Tiffs are layered 

Making Selections 

Add to Selection 
Click on Add to selection  or Hold down the Shift Key as you drag the Selection Tool

Subtract from Selection 

Click on the button to subtract from an existing Selection or hold down the ALT key 

Feather 

Feathering creates a gradual transition between the inside and outside border

Shape Selection Tools  
 Shift M 

Rectangular Marquee

To select square or Rectangle Marquee

Elliptical Marquee

To create ellipses or circles.

(Normal)

(Fixed Ratio)

Single Marquee

· Open a RGB document with a single white background 

· Select a Single Column of Pixels near the centre of the image

· Choose Filter/ Noise/ Add Noise / 400 and click ok 

· Choose Edit/ Transform/ Scale/ Drag the middle handle of the Left and right side of the Bounding box 
· Press Enter to Return and ESC to cancel 

· Choose Image/Adjustments /Hue/Saturation 

· Select the colorize box and move the Sliders till the image changes to the desired colour 

Free Form Selection Tools 
Photoshop offers three tools for making irregularly shaped selections. Shift L
Lasso 

The Lasso draws free-form selections. Close the Marquee by placing the cursor on the starting point
Polygonal Lasso 

Creates straight edged borders Click and release the mouse Repeat the process until you return to the point of origin 

Magnetic Lasso makes selections based on the contrast values. As you click and drag the Magnetic Lasso deposits a path that is attracted to the edge of two contrasting areas

Edge Contrast 

The higher the number, the smaller the range of contrast 

Frequency 

The amount of Anchor points are placed 

Shortcuts

CTRLA – Select All

CTRL D –Deselect

Reselect -SHIFT CTRL D 

Inverse -SHIFT CTRL I\

ALT CTRL Z for multiple shifts
ALT CTRL to make copies of the selection 

CTRL a shortcut to move   

Select Modify 

Border

Smooth

Expand and Contract 

Magic Wand 

Select Inverse CTRL SHIFT I 

Project 

	Do Now 

Feathering example.psd
Ducky.tif
Hands_On1_START.psd
Hands_On1_End.PSD
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	 Lesson Two 
	Undoing Changes and mistakes
To undo the last operation you have just completed 
Edit Undo or CTLZ

To undo all the changes made to the image go to the File Menu and choose Revert 

History Palette 

By Default the History Palette remembers the only last 20  operations 

Snapshots 

Allows you to make a temporary copy of any state of your image 

Clear History 
History Brush 

The history brush allows you to paint from a previous snapshot. You need to ensure that the two states have the same colour mode and image size 
Layers

Create an A4 page and using Ruler Guides create 6 squares. Open the ducky and use the Magic Wand and Select and then Inverse. Select image/adjustments/variations

CTRL to select the layers.

Name a Layer 

Change the order

Delete a layer

Visibility

Opacity

New Layer

Duplicate Layer

Merge Visible

Flatten Image 

Hue Saturation 
Click on the layer in the Layers palette
Go to the Image Menu and choose Adjustments and Hue Saturation 

Variations 

Click on the Layer in the Layers Palette of the Duck you want to change

Go to the Image menu and choose Adjustments and then variations 

To add some texture to this background

Go to the Filters Menu and choose Texturiser 

Applying Layer Styles 
Create an A4 page and using Ruler Guides create 6 squares. Open the ducky and use the Magic Wand and Select and then Inverse. Select image/adjustments/variations

CTRL to select the layers.

Target the Layer

Choose Layer  /Layer Style

Drop Shadow

Inner Shadow

Outer Glow

Inner Glow

Bevel and Emboss

Pattern Overlay 
Stroke 

Layer Revision 
Text 
To highlight text so it can be edited, click in front of it 

To select a word double click it 

To select a line of text triple click it 

To select all the characters in a bounding box CTRL A 

When you select the textit goes into Edit mode 

There are four types of Font
Vertical

Horizontal

Vertical Mask 

Horizontal Mask 

Enter Type in a Bounding Box 

If needed readjust the size of the bounding box by dragging the corner or any of the points 

Placing Text on a Path 

Draw a Shape using the Pen Tool or any Shape Tool 

Click the path or outside of the shape 

If you want to move the text along a path or inside a shape Select the Path Selection Tool 

Text Palette Bar 
Horizontal

Vertical
Font

Size 

Alignment

Colour

Warping Text 

Creating Horizontal Text 

 Choose a Font 
Choose a Size

Choose a Colour

Type in Island Holiday

To make the Text stand out more select a rectangle marquee area on the image and fill with white Make it about 50% opacity. 
Type Mask Tool
Open a new File 10cmX4cm
Edit Menu and fill with Black 

Create a new Layer

Click on the Foreground colour box and choose a Red Colour 

Click on the Type Mask Tool and then on the image

Enter the text Canterbury in 48 pt Bold

Edit Menu and choose Fill , use Foreground colour 

Select Menu/ Modify and Border
Enter 4 pixels 

Go to the Edit Menu and fill with White 

Adding a Pattern 
You use the Edit > Define Pattern command to create new patterns based on a selection.

To define a preset pattern: 

1. Use the Rectangle Marquee tool [image: image1.png]


on any open image to select an area to use as a pattern. Feather must be set to 0 pixels. Note that large images may become unwieldy. 

2. Choose Edit > Define Pattern. 

3. (Photoshop) Enter a name for the pattern in the Pattern Name dialog box. 

Note: If you are using a pattern from one image and applying it to another, Photoshop converts the colour mode.

Go to the File menu and Choose New 
Make it 10cm by 4 cm 

Click on the Type Mask Tool and then on the image 

Enter Clouds in a large 48pt and Bold 

Edit Menu and choose Fill Use Pattern 

Save as Clouds Text 

With the text still selected go to the Select Menu and choose Border

Make the Border 2 pixels wide 

Go to the Edit Menu and choose Fill with Black 
	Do Now

Ducky.tif
Flying_Women_start.psd
Palm Tree.tif
Big sky.tif
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	Lesson Three
	Do Now 
Adding Filters 
You use the Edit > Define Pattern command to create new patterns based on a selection.

To define a preset pattern: 

4. Use the Rectangle Marquee tool [image: image2.png]


on any open image to select an area to use as a pattern. Feather must be set to 0 pixels. Note that large images may become unwieldy. 

5. Choose Edit > Define Pattern. 

6. (Photoshop) Enter a name for the pattern in the Pattern Name dialog box. 

Note: If you are using a pattern from one image and applying it to another, Photoshop converts the colour mode.

Go to the File menu and Choose New 

Make it 10cm by 4 cm 

Click on the Type Mask Tool and then on the image 

Enter Clouds in a large 48pt and Bold 

Edit Menu and choose Fill Use Pattern 

Save as Clouds Text 

Go to the Filter menu and choose embossed 

Now experiment with other Filters 

Colour Modes 

Foreground and Background Colours

The Colour Picker 

 Image/ Modes 

Colour /Swatches /Styles 

Only Web Colours 
Pick the Colour Picker 

If you know the Web Colour check the hexadecimal box 

Eraser Tools
Eraser

The Pixels are changed to the Background Layer or if in a locked layer it changes to transparency 

The Magic Eraser 
When you click in a layer with the magic eraser all similar pixels are erased

Brushes

To load a Brush 

Go to the Edit Menu and choose Preset Manager

Click on Load 

The brush should appear in the Brushes palette  
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	Lesson Four 
	Do Now 
Fonts
Layer Styles 

Resolution 

Resolution is measured in pixels. The physical size of pixels change according to what resolution you have chosen. The lower the resolution, the fewer pixels to an image 

For print it is 300 dpi 

For the Web it is 72 DPI

When combining images from different graphics, it is easier if both graphics are the same resolution.
To change the resolution of an image
Go to Image and choose Image Size

Enter the width and Height 
Enter the Resolution

The Cropping Tool

Specifying Width and Height 

Perspective Cropping 

The Magnifying Tool 
CTRL+

CTRL-

The Extract Filter 

Sizing the Canvas 

Choose Image/Canvas Size
Check the Relative Box 

Check the centre box to anchor the image to the centre 

Choose a colour 
Experiment with changing 
Edit Transform 

Skew 
Distort

Perspective

Rotate 180  Rotate 90

Flip Horizontal

Flip Vertical      
 Clone Stamp Tool 

 To clone an area you must sample it by Picking ALT 
Choose an appropriate Brush 

Press ALT  key the point you wish to copy 

Release your mouse and position the curser over the area you wish to copy and begin painting 
Pattern Stamp Tool 

Use the Pattern Stamp to paint an area with a repeating pattern. The Options Bar provides you with several Default Patterns or you can check the impressionist box the pattern will be applied with an impressionist style painting effect 

Healing Brush 

The Healing Brush acts the same as the Cloning Brush but it takes on the characteristics of the surrounding pixels.

Gradients

Select the Gradient Tool next to the Paint Bucket 
Select an A4 Page 

And apply a Gradient to it 

Choose what type of Gradient you wish to apply 

Vignettes

Choose the Feather lasso and set Feather to 40 pixels 

Go to Select Inverse 

Click on the Gradient Tool button 

Click in the middle and drag to the edge.
Making Buttons 

Making Banner
	mandrillR.psd
Eagle.tif
rhinoroom.psd
ge_radio.psd
clone_practice.psd
heal_me_patch_me.psd
Eagle.tif
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	 Lesson Five
	 Do Now 
Look at Web Pages 
 Elements that make up a Web Page 

Banner

Navigation Bar 

Text Navigation Bar 

Side Bar 

Buttons

Pictures 

Collect images and design the layout of your page

Discussion on HTML 

(Hyper text Markup Language )

WYSIWG

Draw a Plan Planning is crucial when designing a website 

Peruse different websites and find the main features or elements that make up a website 

Criteria for Designing a good website. Design a table into two columns. Do’s and Do Nots 

In other words what makes a good website and what makes a bad website 

Develop criteria on what makes a good website

Create a Folder name it Alpine Retreats 

In that Folder Create a new Folders

HTML Files

Images

Library

Open up Dreamweaver 

Go to Dreamweaver Site
Click on the Advanced Site

Expanding and Collapsing panels 

Select File New 

Basic Page HTML

Elect Create 

Deleting a Page 

Saving a Page as a Template 
Files Refresh button 

The Insert Bar 

Show as Tabs 

Create a Table

Insert a Table 
3 Rows

3 Columns

Border 0

Modifying Page properties

Properties Inspector Panel
You can add or delete the Bottom row or right hand column by changing the number of rows and columns in the properties table inspector 
Make sure the Table is selected 

Change the number of rows to 2 columns and four rows 

Another way is to add a row  is to place the cursor in the last cell and tab
Inserting or deleting a row or column in the middle of a table  

Right Click Mouse on the top left cell in the table 

Select Table, Insert Column 

The Table should have 3 columns 

Merging and Splitting Cells 

Select the Entire row in the Table lick Merge cells 

Splitting

Select the centre cell in Row 3

Click the Split cells icon 

Resizing Cells 

Saving as a Template 


	Do Now
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	Lesson Six 
	 Do Now 
Inserting Images
Select Insert Image from the Insert Bar 

Previewing 

File Preview image in Browser 

Borders 

To change the Colour of cells 

Click in the Last cell in Row 3

Click the small grey box labelled Bg 

Adding Cell Colour with the eye dropper 

Editable Regions 

Click in the centre in Row 3 

Click in the Insert bar 

Click the Templates icon
Click Editable Region

Horizontal and Vertical Alignment 

Left and Vertical Top 

Adding Navigation Bar 

Click on the Bottom Left Hand Cell

Make sure the cell is vertically aligned 

Select Navigation bar 

The First Button will be the Home Page 

Then Browse for the Up image 

Then add another button by clicking on the + button

Enter Resort as the name 

Preview in Browser F12

Making the Home Page 

Select File/ New 
Click on the Templates Tab

Click Create 
Try changing any part of the template that you didn’t specify as editable and it will be locked 

Click on the title and change it to Home 

Inserting a Table 
Delete the text in Editable Region and insert a Table 400 pixels wide 

3 columns by 3 columns 

NB most of your files will be saved in the Html folder the Home or index page will be saved in the root directory

Save as index.html

Click the cursor in the last cell in row 2. Locate the chalet_vert file under the Images/Chalet/photos. Select it and then click OK 

Change it to appear in the middle of the cell by clicking the cursor in the <TD> tag in the tag inspector 

Now add text from the Folder Text for Resorts.
Email 

Click the e-mail link on the Insert bar 

Enter the Information by adding your email address 

Title 
Search Engines 

Different Views
Code/Split/Design 

	Do Now
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	Lesson Seven
	Do Now 

 Creating the Resort Page
File New 

Select Templates Page 

Create

Replace the Page Title with Resort
Insert a Table in the Editable Region 400 pixels Wide 5 Rows 3 columns 

Insert the Images to go with each paragraph. Copy and Paste the text from the Resort folder.

Named Anchors

 Place the cursor at the beginning of the Tile Resort and Enter
Enter the Text Resort | Apres Ski| Weather| Maps

Place the cursor to the left of the first word in the first paragraph 

Enter Resort

A Small anchor will appear 

Do the same for the remaining paragraphs

Double Click the word Resort Type in #Resort

External Link 

Select the text www.valthorens.com
In the Link Field in the Properties Inspector type in http://www.valthorens. Com

Select Blank in the Target field so the link will open up in a new window.

Save as Resort Page in the Html folder 

Forms 
Create a new page based on a template 

Save it as Booking.html 

On the Insert Bar Select the Forms tab

Click in the Page Content Editable Region 

Enter to expand it 

Click the Form icon 

Inside the Form Icon 

Create a Table 15 rows, 7 columns 

Merge the First row 

Please fill in your details and we will contact you.

In the second row, second column add title 

Click the Text field icon 

Name it First Name 
Set Char Width to 20 in the Properties Inspector 

In the Fifth column type in Title 

Click in the next column 

Click in the Lists menu 

Name the Field Title 

Adding Values 

Add Mr 

Miss 

Mrs

Select the Default Value

Radio Group

Click on the Radio Button 
To enter values for the buttons click on the Radio + 
List the Label and Value 

Submit and Reset Button 

Adding a big Text Area 
 Char Width 45 Num Lines 4 
Submitting the Form 
Select the whole form . In the Properties inspector name the form Booking Form 

Action Field Add your email

Save 


	Do Now
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	Do Now 

Making Banners 
Making Buttons 


	Do Now 
Instructions for making buttons.doc
Steps to create a Banner.doc
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	Do Now 

 
	Do Now 
 
	 








